Results 1 to 3 of 3
  1. #1
    I'm new here, please be nice
    Join Date
    Sep 2018
    Posts
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Gearbox shifting too early

    hey there, i have recently bought a 2002 Holden/Opel Astra ts city 1.8 litre and the automatic transmission has a few problems. The first problem is when its cold and you first put it into drive it shutters and stalls straight away but if its warmed up it doesn't stall. another problem is when taking off it will go through first gear then into 2nd for about 1 second then shift straight into a high gear, causing the engine to shutter and shake a lot. Some forums say its the snow button on the side but I have disconnected the button entirely and it still goes straight to top gear. I would greatly appreciate if someone had any idea about whats going on or if anyone has had a similar problem to tell me about it and what you have done to fix this issue.

    Thank you Click here to enlarge.

  2. #2
    OpelAus Participant ZomBie's Avatar
    Join Date
    Nov 2011
    Location
    Sydney
    Posts
    169
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    How many km's on the gearbox?

    Many years ago my g/f's car (not an astra/opal) had the opposite problem, where it wouldn't change gear.
    The fluid in it was so old that the hydraulics and wotnot just had gunk and airbubbles and whatever, and basically wasn't working. A flush, service, and refill, and it was all good again!

  3. #3
    I'm new here, please be nice
    Join Date
    Sep 2018
    Posts
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Only done 180,000 ks and i just replaced the transmissiom fluid thursday night but i think it may be a shifter solenoid

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •